Incident - September 10, 2019
Incident Report for AppointmentPlus
Resolved
This incident has been resolved.
Posted 14 days ago. Sep 10, 2019 - 13:42 PDT
Investigating
We are investigating a potential issue. Our team is currently looking into this and we will provide an update within the next 30 minutes. We apologize for any inconvenience.
Posted 14 days ago. Sep 10, 2019 - 13:25 PDT
This incident affected: Customer View.