December 22 -
Incident Report for DaySmart Appointments
Resolved
This incident has been resolved.
Posted Dec 22, 2021 - 07:05 PST
Identified
Some are experiencing issues getting to their account, please use: https://account.appointment-plus.com/ap/ap_admin_v2/login.php to reach the log in page!
Posted Dec 22, 2021 - 06:16 PST
This incident affected: Site Admin.