Latency Issues
Incident Report for DaySmart Appointments
Resolved
This incident has been resolved.
Posted Mar 21, 2023 - 17:20 PDT
Monitoring
Thank you for your patience today. We are seeing material improvements in the latency issues after moving some of our highest-volume workloads to a secondary storage system. We saw immediate improvements to latency and throughput, and at this time we will be continuing to migrate workloads to this secondary environment over the course of the evening. We expect performance to improve throughout the night as we continue to implement this plan. We will provide updates on progress as needed.
Posted Mar 20, 2023 - 16:56 PDT
Update
Thank you for your patience today. We are seeing material improvements in the latency issues after moving some of our highest-volume workloads to a secondary storage system. We saw immediate improvements to latency and throughput, and at this time we will be continuing to migrate workloads to this secondary environment over the course of the evening. We expect performance to improve throughout the night as we continue to implement this plan. We will provide updates on progress as needed.
Posted Mar 20, 2023 - 15:58 PDT
Update
At this time we are working through best options to improve latency. As a reminder we ask that staff members allow the system to fully load all appointments in the Site Admin.
Posted Mar 20, 2023 - 13:46 PDT
Update
We have some positive movement coming in regards to a resolution that would restore the speed in your account. As we gather more information to implement this solution, we will be reaching out with an update.
Posted Mar 20, 2023 - 12:52 PDT
Update
We are still working to resolve the issues with latency upon logging in/scheduling appointments. Although access to booking has improved we are aware of issues reported with slowness when booking in the client view.

As a reminder we ask that staff members allow the system to fully load all appointments in the Site Admin.
Posted Mar 20, 2023 - 11:51 PDT
Update
We are still working with the storage vendor to troubleshoot what's causing the slowness with writes. Unfortunately, we don't have a timeline yet, but we are continuing to push for a resolution time.

That being said, we are still seeing that most customers should be able to successfully log in to DaySmart Appointments but will continue to experience system slowness or intermittent errors for the time being. We advise you to allow Site Admin appointments to fully loads instead of repeatedly attempting to load to improve functionality.
Posted Mar 20, 2023 - 11:15 PDT
Update
Thank you for your continued patience. At this time, most customers should be able to successfully log in to DaySmart Appointments, but will continue to experience system slowness or intermittent errors for the time being. We will continue to keep you updated as more information becomes available.
Posted Mar 20, 2023 - 10:14 PDT
Update
We are seeing high latency on the storage layer when writing records. High latency will cause requests to take longer. At this time we do not have an estimated time of resolution, however, we are investigating this further for a solution.
Posted Mar 20, 2023 - 10:07 PDT
Update
We sincerely apologize for the inconvenience this has brought. . We have narrowed down what may have caused the issue and are working diligently to find a resolution.
Posted Mar 20, 2023 - 09:15 PDT
Update
Our team has all hands on deck and working to find the root cause of the errors seen. We apologize for the inconvenience this has caused you and your team. We will be providing another update in 30 minutes.
Posted Mar 20, 2023 - 08:20 PDT
Investigating
We are seeing severe latency on the staff member login as well as the client login when logging into accounts. We are investigating the issues seen and will provide an update on the resolution.
Posted Mar 20, 2023 - 07:45 PDT
This incident affected: Web Services, Site Admin, Customer View, and Sandbox.