We are seeing improvement with logging in as well as increased speeds. We apologize for any frustrations this has caused you and your team. Thank you for your patience.
Posted Oct 26, 2024 - 08:36 PDT
Update
We are seeing some improvement with logging in however our team is continuing to investigate the issues you are experiencing. We apologize for any frustrations this has caused you and your team. We will provide another update as soon as we know more.
Posted Oct 26, 2024 - 08:12 PDT
Update
We are continuing to investigate this issue.
Posted Oct 26, 2024 - 07:40 PDT
Update
We are receiving reports of clients experiencing latency and/or unable to log in. The team is currently looking into this issue. We apologize for the interruption in your service.
Posted Oct 26, 2024 - 07:40 PDT
Investigating
Our team is investigating account slowness and will provide an update as soon as possible. Thank you for your patience.
Posted Oct 26, 2024 - 07:16 PDT
This incident affected: Web Services, Site Admin, and Customer View.