Our team has identified the issues reported for account slowness. With close monitoring we have seen this issue has been resolved
Posted Aug 07, 2024 - 16:10 PDT
Monitoring
We have seen improved speeds and will continue to monitor this for the next several hours. We ask that you allow time for the page to load in order to continue with account activity. Thank you for your continued patience.
Posted Aug 07, 2024 - 15:23 PDT
Update
Our team is currently investigating issues with account slowness and working on a solution. During this time, we ask that you please allow time for the page to load in order to continue account activity.
Posted Aug 07, 2024 - 12:24 PDT
Update
We will be rebooting our DNS servers to improve the account slowness. While this should not affect your operations you could see down times around two to three minutes. Please reach out to us if you have any further questions or concerns.
Posted Aug 07, 2024 - 11:35 PDT
Update
As of 2:00pm EDT we are still trying to resolve the issues were having with system slowness. We apologize for the inconvenience and will update you as soon as we know more.
Posted Aug 07, 2024 - 11:09 PDT
Update
At 1:45pm EDT we will be restarting our server to try and resolve the issue. While this should not affect your operations you could see down times around 1 minute. Please reach out to us if you have any further questions or concerns.
Posted Aug 07, 2024 - 10:43 PDT
Identified
Our team has identified the issue causing system slowness and continue to work through implementing a solution. We thank you for your patience during this time and will continue to provide updates as we work towards a resolution.
Posted Aug 07, 2024 - 09:49 PDT
Investigating
Our team has identified account latency and are working to resolve this. We will be providing updates to this page as we continue our investigation. Thank you.